Support

  1. resif
  2. General
  3. Wednesday, March 03 2021, 06:07 PM
  4.  Subscribe via email
after reinstall my vps server i am receiving this error
admin Accepted Answer
Admin
Hi,
try to delete folder "cache" at /plugins/jsn/socialnetwork/app/tmp/
  1. more than a month ago
  2. General
  3. # 1
resif Accepted Answer
Pro
i deleted all directory and files under cache didnt work i deleted cache directory didnt work out again
  1. more than a month ago
  2. General
  3. # 2
admin Accepted Answer
Admin
Please post me your site details to check this. You xan ise the form below the reply in Site Details tab.
  1. more than a month ago
  2. General
  3. # 3
resif Accepted Answer
Pro
ok i sent
  1. more than a month ago
  2. General
  3. # 4
admin Accepted Answer
Admin
Hi,
seems that the folder /plugins/jsn is not writable by the webserver (see screenshot), so probably the webserver is not able to write cache folder.

Unfortunately via FTP I'm not able to change permission.
Attachments (1)
  1. more than a month ago
  2. General
  3. # 5
resif Accepted Answer
Pro
ok 755 or 777 which?
  1. more than a month ago
  2. General
  3. # 6
admin Accepted Answer
Admin
This depends of the owner of the files, anyway in according with all others writable folder you can set it with 777.
  1. more than a month ago
  2. General
  3. # 7
resif Accepted Answer
Pro
what?

should i make all joomla 777

for hack...

what are you tlaking about..

please tell me only easy profile permissions settings for all easyprofile social network directory and files..

is there any wiki about this
  1. more than a month ago
  2. General
  3. # 8
resif Accepted Answer
Pro
i did my directories and my files 777 and worked...

is this a permanent ad safe solutions...
  1. more than a month ago
  2. General
  3. # 9
admin Accepted Answer
Admin
Hi,
what?

should i make all joomla 777
You already have all files and directory with 777 permission....only some exceptions like Easy Profile plugin folder


s this a permanent ad safe solutions...
I does not recommend to set all your file to 777...but now it is already so. The best way is to change owner of the files and set something like 755.

NOTE: owner of the files should be the webserver user, in a normal configuration you should have a user for each virtualhost but it's possible that your webserver is configured to have only one user (normally called "www" or "www-data" with apache webserver)
  1. more than a month ago
  2. General
  3. # 10
resif Accepted Answer
Pro
hello

after when reinstall my vps

all share status not working... image or youtube else...
  1. more than a month ago
  2. General
  3. # 11
admin Accepted Answer
Admin
Hi,
the error is "SQLSTATE[HY000]: General error: 1364 Field 'text' doesn't have a default value".
This mean that a column 'text' in table '#__jsnsocial_activities' does not have a default value. But as you can see from SQL installation file at /plugins/jsn/socialnetwork/sql/install.sql at line 7 there is a declaration of default value
`text` text COLLATE utf8_unicode_ci NOT NULL DEFAULT '',


I have fixed this for you by adding a default value for columns 'text', 'items' and 'params' (basically all text type columns in table '#__jsnsocial_activities'). Have you imported the database from another server? if yes then maybe it's possible that during the export process the SQL server have not exported all columns definitions (at least the default value for text column type).
  1. more than a month ago
  2. General
  3. # 12
resif Accepted Answer
Pro
how this can be i exported from phpmyadmin and imported...

and no image ada still not working... ...
  1. more than a month ago
  2. General
  3. # 13
resif Accepted Answer
Pro
look attacment what i see when i try upload a image
Attachments (1)
  1. more than a month ago
  2. General
  3. # 14
admin Accepted Answer
Admin
Hi,
the error is "SQLSTATE[HY000]: General error: 1364 Field 'caption' doesn't have a default value" (referred to table #__jsnsocial_photos), so still something related to default values.

I don't know why all default value was removed from your tables definition, I suppose this happened during some import/export DB.

Now the fastest way to solve all these problems is to remove the MySQL configuration called "STRICT_TRANS_TABLES" (https://www.knowledgebase-script.com/kb/article/how-do-i-disable-strict-mode-in-mysql-163.html). Otherwise you need to set manually default value for all column of type TEXT with a tool like PhpMyAdmin
  1. more than a month ago
  2. General
  3. # 15
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Request Support

Support is currently Offline

Support Availability

Working days: Monday to Friday. The support staff is not available on weekends; in the most of cases tickets will not be answered during that time.

Reply time: Depending on the complexity of your support issue it's usually between a few minutes and 24 hours for paid members and about one week for free members. When we expect longer delays we will notify you.

Guidelines

Before you post: read the documentation and search the forums for an answer to your question.

When you post: include Site Details if you request a support (you can use the form below the reply in Site Details tab).

Auto Solved Question: If after a week the author of the post does not reply to a request by moderator, the question will be marked as resolved.

Language: only English

Search Users

Easy ProfileĀ® is not affiliated with or endorsed by Open Source Matters or the Joomla Project. Joomla is Free Software released under the GNU/GPL License.