Support

  1. cocojoom
  2. Bug Report
  3. Wednesday, January 29 2014, 10:35 AM
  4.  Subscribe via email
Hello,
The component doesn't work anymore.
When I try to create a new field, a message error appears : "0 SQL=ALTER TABLE arxig_jsn_users ADD `testagain` VARCHAR(255)"
I've updated with the last release but it doesn't change anything.

To be more precise : After the alert message, the field is created and appears in the form.
BUT If I type a text in it, it isn't memorized and the next time it is blank.

Now when I create a new field : new message
error : Strict Standards: Declaration of JsnModelField::delete() should be compatible with JModelAdmin::delete(&$pks) in /homepages/22/d113735792/htdocs/2014/administrator/components/com_jsn/models/field.php on line 14

The site is visible here :
menu INSCRIPTION
If you try to register, coordonnées tab...the last 3 fields are not working.

Thank you for your help, The site should be online at the end of the week...
Attachments (1)
References
  1. http://www.opus-yvelines.org/2014/
admin Accepted Answer
Admin
Hi,
can you please post your site details? (if yes you can use the 'Site Details' Tab below the reply)
  1. more than a month ago
  2. Bug Report
  3. # 1
cocojoom Accepted Answer
Pro
Yes but Is it public informations, visible here or only private ?
  1. more than a month ago
  2. Bug Report
  3. # 2
admin Accepted Answer
Admin
Are private information, only our support team can see!
  1. more than a month ago
  2. Bug Report
  3. # 3
cocojoom Accepted Answer
Pro
ok, here it is.
Thanks
  1. more than a month ago
  2. Bug Report
  3. # 4
admin Accepted Answer
Admin
I think I've figured out the problem.
When you create a field,so Easy Profile create a column on #__jsn_users table that contains the information of users.
But the MySql server have a Hard Limit for number of column. (read this article http://dev.mysql.com/doc/refman/4.1/en/column-count-limit.html)
When the limit is reached you can not create new columns, but Easy Profile still creates record with field information(record in #__jsn_fields).

Do this:
- Delete the last 3 fields that are not working. (this fields not have a column in #__jsn_users)
- Delete the Trashed fields (this allows you to get more free columns on the table)
- Recreate the last 3 fields that are not working.

If occurred an PHP Strict Error, please ignore. (The strict error are hidden if you have php.ini set correctly, as recommended by joomla).
This not are error but are a warning. to hide this set in php.ini the directive display_error=Off (recommended by joomla).
In next release we will try to resolve this warning.
  1. more than a month ago
  2. Bug Report
  3. # 5
cocojoom Accepted Answer
Pro
Thank you, There is no more SQL alert

BUT the field is not working properly.
I mean it is shown in the form,
but when saving the form
modification in the field are not memorized.
the field is blank again.

Thank you for your help
  1. more than a month ago
  2. Bug Report
  3. # 6
cocojoom Accepted Answer
Pro
I've tried to add a field in the first tab, and it seems ok.
Thank you for your help !

I have another question about something else...
Is it possible to upload a file in the subscription form ?
  1. more than a month ago
  2. Bug Report
  3. # 7
admin Accepted Answer
Admin
Is it possible to upload a file in the subscription form ?

For now not, in next release we will add a file type.
  1. more than a month ago
  2. Bug Report
  3. # 8
cocojoom Accepted Answer
Pro
Content Protected
  1. more than a month ago
  2. Bug Report
  3. # 9
admin Accepted Answer
Admin
Can you please attach your PHP error_log in ZIP format?

what are the latest changes?

Can you update to latest version of Easy Profile?

NOTE: I saw that the format of all your options of select / checkbox / radio is wrong. (see screenshot)
Attachments (1)
  1. more than a month ago
  2. Bug Report
  3. # 10
cocojoom Accepted Answer
Pro
Thanks for your reply.
here is the error log...

I try to update the last version.
  1. more than a month ago
  2. Bug Report
  3. # 11
admin Accepted Answer
Admin
This is not the PHP error log!:(

Have you try to adjust the options for checkbox/radio/select?
What are the latest changes?
Can you update to latest version of Easy Profile?
  1. more than a month ago
  2. Bug Report
  3. # 12
cocojoom Accepted Answer
Pro
Hy,

Where can I find it ?
I didn't change anything yet cause it worked properly till a few days.
I've updated the last version yesterday night.

Thanks for your help...
  1. more than a month ago
  2. Bug Report
  3. # 13
admin Accepted Answer
Admin
Hi,
I am solving the problems!
I'm suspending the fields to recreate them.
10 minutes and I adjusted
  1. more than a month ago
  2. Bug Report
  3. # 14
cocojoom Accepted Answer
Pro
ok, sorry I haven't seen your message...
I disconnect and let you do.
  1. more than a month ago
  2. Bug Report
  3. # 15
cocojoom Accepted Answer
Pro
Could you check again,
cause I may have undone
some of what you were doing.

Sorry about that.
  1. more than a month ago
  2. Bug Report
  3. # 16
admin Accepted Answer
Admin
Maybe it's ok. Check please!

I think you have reached the limit of fields. read here http://www.easy-profile.com/support/can-i-make-any-number-of-tabs,-fields.html#reply-495
  1. more than a month ago
  2. Bug Report
  3. # 17
cocojoom Accepted Answer
Pro
Content Protected
  1. more than a month ago
  2. Bug Report
  3. # 18
admin Accepted Answer
Admin
This because you have not respected the options format for select, radio, checkbox!

see screenshot for 'EPREUVE' field, now I have fix for this field and search work)
Attachments (1)
  1. more than a month ago
  2. Bug Report
  3. # 19
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.
Sorry, the discussion is currently locked. You will not be able to post a reply at the moment.

Request Support

Support is currently Offline

Support Availability

Working days: Monday to Friday. The support staff is not available on weekends; in the most of cases tickets will not be answered during that time.

Reply time: Depending on the complexity of your support issue it's usually between a few minutes and 24 hours for paid members and about one week for free members. When we expect longer delays we will notify you.

Guidelines

Before you post: read the documentation and search the forums for an answer to your question.

When you post: include Site Details if you request a support (you can use the form below the reply in Site Details tab).

Auto Solved Question: If after a week the author of the post does not reply to a request by moderator, the question will be marked as resolved.

Language: only English

Search Users

Easy Profile® is not affiliated with or endorsed by Open Source Matters or the Joomla Project. Joomla is Free Software released under the GNU/GPL License.