Support

  1. zuotoski
  2. Bug Report
  3. Saturday, May 23 2015, 04:05 AM
  4.  Subscribe via email
Hi,

Recently Youtube has changed their connection API, they've put it in action about 1 month ago. After this I can no longer post videos on my profiles, because the old API can not connect with the new one, then it can not retrieve any information from Youtube resulting in an valid link. You can see some attempts that I've made by accessing here: http://www.zpeed.com.br/social/videos

Here is something about it: http://googledevelopers.blogspot.com.br/2015/03/reminder-to-migrate-to-oauth-20-or.html

I was having problems with Steam Games trying to retrieve videos from Youtube, the problem was the same: old API connection, which is now replaced on Steam and everything is working fine back again

Any suggestions? Can I solve this by myself?

Thanks
References
  1. http://www.zpeed.com.br/social/videos
Accepted Answer
admin Accepted Answer
Admin
Hi,
attached to this post you will find archive with 2 files, you need to copy in correct folders

- Video.php into /plugins/jsn/socialnetwork/app/Model/
- VideosController into /plugins/jsn/socialnetwork/app/Controller/
Attachments (1)
  1. more than a month ago
  2. Bug Report
  3. # Permalink
admin Accepted Answer
Admin
Hi Alex,
thanks for report this, we will send you a quick fix and solve this in next release.
  1. more than a month ago
  2. Bug Report
  3. # 1
zuotoski Accepted Answer
Hi,
Thanks for the quick reply. As it's not possible to edit my own post, I'll reply to correct a mistype. Where I say "results in an valid link." I mean to say "results in an invalid link".

Cheers.
  1. more than a month ago
  2. Bug Report
  3. # 2
admin Accepted Answer
Admin
Hi Alex,
I know :D

from 20 April Youtube (Google) have deprecated API 2.0, so now we need to use API 3.0.

unfortunately with API 3.0 there is a small limit, We can get all data of videos except the description. To retrieve description of Video is necessary to create a Google App with Youtube API enabled, but we add this in only next release.

So we will send you the code (30 minutes) but this will not work with the video description :(
  1. more than a month ago
  2. Bug Report
  3. # 3
zuotoski Accepted Answer
Content Protected
  1. more than a month ago
  2. Bug Report
  3. # 4
zuotoski Accepted Answer
Easy Profile Support wrote:

Hi,
attached to this post you will find archive with 2 files, you need to copy in correct folders

- Video.php into /plugins/jsn/socialnetwork/app/Model/
- VideosController into /plugins/jsn/socialnetwork/app/Controller/


Hi!
I can confirm that it is working fine now. As you said, the only thing that is missing is the video description, but it's not a big deal.

Thank you very much for your fast and kind support.

Cheers.
  1. more than a month ago
  2. Bug Report
  3. # 5
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.
Sorry, the discussion is currently locked. You will not be able to post a reply at the moment.

Request Support

Support is currently Offline

Support Availability

Working days: Monday to Friday. The support staff is not available on weekends; in the most of cases tickets will not be answered during that time.

Reply time: Depending on the complexity of your support issue it's usually between a few minutes and 24 hours for paid members and about one week for free members. When we expect longer delays we will notify you.

Guidelines

Before you post: read the documentation and search the forums for an answer to your question.

When you post: include Site Details if you request a support (you can use the form below the reply in Site Details tab).

Auto Solved Question: If after a week the author of the post does not reply to a request by moderator, the question will be marked as resolved.

Language: only English

Search Users

Easy ProfileĀ® is not affiliated with or endorsed by Open Source Matters or the Joomla Project. Joomla is Free Software released under the GNU/GPL License.