Support

  1. klox7
  2. Bug Report
  3. Sunday, April 12 2015, 09:25 PM
  4.  Subscribe via email
Hello,

I'm encountering some problems when user that was already registered logs in after I added additional required fields to profile.

Let's say I added new field "Country" which is required.

After existing user logs in it redirect him to profile registration edit layout. When user fills this new required field and clicks submit he gets warning for password field.

Why is this so? This user was already registered and has a password, he only needs to fill this new required field value. Even if he sets password and submits he gets another warning that his username already exists.

And with this scenario user can only log out.

Regards
admin Accepted Answer
Admin
Hi,
try to create a menu item of type Users Manager->Edit User Profile.

if not work, please post me your site details (you can use the form below the reply in "Site Details" tab), we will check your configuration.
  1. more than a month ago
  2. Bug Report
  3. # 1
klox7 Accepted Answer
Hello, thanks that worked, but why is that? Can I do it without menu item?
  1. more than a month ago
  2. Bug Report
  3. # 2
admin Accepted Answer
Admin
Hi,
but why is that?
sometimes Joomla have a strange redirect.

When Joomla try to redirect on Edit Profile page it search some menu item of components com_users. if you have only menu item of type Registration then Joomla will redirect on it (so required password as a new registration). The solution is to create a menu item of type Users Manager->Edit User Profile or Users Manager->User Profile.

Can I do it without menu item?
If you keep a menu item of type Registration you need to work with this menu item. You can add Edit Profile menu item in a hidden menu.
  1. more than a month ago
  2. Bug Report
  3. # 3
klox7 Accepted Answer
Content Protected
  1. more than a month ago
  2. Bug Report
  3. # 4
admin Accepted Answer
Admin
Hi,
I tried and seems some problem of Company Name, Company Adress and Company City fields.

Do you have enabled some your custom plugins?
  1. more than a month ago
  2. Bug Report
  3. # 5
klox7 Accepted Answer
Content Protected
  1. more than a month ago
  2. Bug Report
  3. # 6
klox7 Accepted Answer
Oh, user type field has conditions...
  1. more than a month ago
  2. Bug Report
  3. # 7
klox7 Accepted Answer
Content Protected
  1. more than a month ago
  2. Bug Report
  3. # 8
admin Accepted Answer
Admin
Hi,
can you please post me details of account with this error? you can use the form below the reply in "site Details" tab.
  1. more than a month ago
  2. Bug Report
  3. # 9
klox7 Accepted Answer
Hi, here you go.
  1. more than a month ago
  2. Bug Report
  3. # 10
admin Accepted Answer
Admin
Hi,
I have checked this profile, and the problem is that not store Company infos, can you please send a backend access to check your configuration?
  1. more than a month ago
  2. Bug Report
  3. # 11
klox7 Accepted Answer
Content Protected
  1. more than a month ago
  2. Bug Report
  3. # 12
admin Accepted Answer
Admin
Ok, now I have understand,
this is a bug, try to install this plugin from coming soon version (some days to release).
Attachments (1)
  1. more than a month ago
  2. Bug Report
  3. # 13
klox7 Accepted Answer
I think that now fields that are not required have problem.
  1. more than a month ago
  2. Bug Report
  3. # 14
admin Accepted Answer
Admin
Can you explain me better? I can't try because account now is blocked
  1. more than a month ago
  2. Bug Report
  3. # 15
klox7 Accepted Answer
Content Protected
  1. more than a month ago
  2. Bug Report
  3. # 16
admin Accepted Answer
Admin
Sorry but with Chrome no error, I found only this:
Uncaught SyntaxError: Unexpected token <


this is not Easy Profile error
Attachments (1)
  1. more than a month ago
  2. Bug Report
  3. # 17
klox7 Accepted Answer
Content Protected
  1. more than a month ago
  2. Bug Report
  3. # 18
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.
Sorry, the discussion is currently locked. You will not be able to post a reply at the moment.

Request Support

Support is currently Offline

Support Availability

Working days: Monday to Friday. The support staff is not available on weekends; in the most of cases tickets will not be answered during that time.

Reply time: Depending on the complexity of your support issue it's usually between a few minutes and 24 hours for paid members and about one week for free members. When we expect longer delays we will notify you.

Guidelines

Before you post: read the documentation and search the forums for an answer to your question.

When you post: include Site Details if you request a support (you can use the form below the reply in Site Details tab).

Auto Solved Question: If after a week the author of the post does not reply to a request by moderator, the question will be marked as resolved.

Language: only English

Search Users

Easy ProfileĀ® is not affiliated with or endorsed by Open Source Matters or the Joomla Project. Joomla is Free Software released under the GNU/GPL License.