Support

  1. kennethefford
  2. Bug Report
  3. Wednesday, June 07 2017, 03:54 PM
  4.  Subscribe via email
Hi,

I am using Easy Profile 2.3.1 and SocialConnect 1.0.0 and am finding that SocialConnect does not work.

Plus, it is causing a JavaScript error as shown in the attached file. As a result I have been forced to disable SocialConnect. How do I fix this?

Ken
Attachments (1)
admin Accepted Answer
Admin
Hi,
probably you have many instances of JQuery Javascript library.

To load this library all components should use Joomla 3 APIs, but some component to keep compatibility with Joomla 2.5 load own JQuery framework, this create conflicts and bad performances.

please post me your site link to find the component/module that cause this problem, many old components have a option to enable/disable jquery load.

Also keep in mind that many instance of jQuery cause more load to open your site (~200Kb) and can create some conflict.
  1. more than a month ago
  2. Bug Report
  3. # 1
kennethefford Accepted Answer
Pro
Thanks, the site is,

https://sim-x.net
  1. more than a month ago
  2. Bug Report
  3. # 2
admin Accepted Answer
Admin
Hi,
there is only one jQuery Frameworks, so I suspect a conflict between Mootools Framework and jQuery Framework. But I can't
check this, because Social Connect seems not enabled (no javascript and no errors in console)
  1. more than a month ago
  2. Bug Report
  3. # 3
kennethefford Accepted Answer
Pro
I can enable temporarily, if that helps. I just cannot leave it enabled right now because the error prevents other scripts from running properly. Please advise.

Ken
  1. more than a month ago
  2. Bug Report
  3. # 4
admin Accepted Answer
Admin
Hi,
we have UTC+2, so now we are at 19:30....too late :(
You seems to come from Canada (from avatar), so tomorrow when we open we will reply to this ticket and wait your response.

Alternative is to give us a backend access.
  1. more than a month ago
  2. Bug Report
  3. # 5
kennethefford Accepted Answer
Pro
That's fine, and thanks. I will setup a backend access account for you later today. That would probably be easier for you.

But please, if the problem remains disable socialconnect until it gets resolved. I will leave it disabled myself and you enable/disable as needed.

I am not sure why Mootools is even loaded, I am not aware of any extension, or template component, that requires it.

Ken
  1. more than a month ago
  2. Bug Report
  3. # 6
kennethefford Accepted Answer
Pro
login details were emailed to webmaster@easy-profile.com
  1. more than a month ago
  2. Bug Report
  3. # 7
admin Accepted Answer
Admin
Hi,
now plugin is enabled and no javascript errors found.

Maybe error was due to JCH Optimize (from your screen I see something related to jscss.php that comes from JCH).

Of course Easy Profile works with JCH Optimize (we use it on this site :) ), but maybe you need to found correct configuration. Now JCH plugin is disabled but I have tried to enable it with "Average" configuration and still no problem found.
  1. more than a month ago
  2. Bug Report
  3. # 8
kennethefford Accepted Answer
Pro
Maybe the error is not site wide. I know I first saw it on this page,

https://sim-x.net/index.php/simsearch/custom-pwc-search-subscriber

and the account I sent you has access to that page, so you can use it to login via the front end. If you do, you need to set some filters to see how I saw the issue,

Engine Manufacturer = Pratt & Whitney
Simulator Type = Full Flight Simulator

Then hit the blue SEARCH button at the bottom.

Thanks.

Ken
  1. more than a month ago
  2. Bug Report
  3. # 9
kennethefford Accepted Answer
Pro
Also, maybe it is from JCHOptimize, and I have had problems using SocialConnect for a while now, and thinking back it was around when I re-enable JCHOptimize. If I try logging into the site using FB or LinkedIn it seems to try but fails. Strange.
  1. more than a month ago
  2. Bug Report
  3. # 10
kennethefford Accepted Answer
Pro
One question, I am seeing the error again. How did you ENABLE JCHOptimize because when I login via the backend it shows as DISABLED.
  1. more than a month ago
  2. Bug Report
  3. # 11
kennethefford Accepted Answer
Pro
Hello, after you have logged in the error is back! I need to reverse what you did immediately, but when I log in JCHOptimize is completely disabled. What did you do? Please explain, or reverse what was done! Thank you.
  1. more than a month ago
  2. Bug Report
  3. # 12
kennethefford Accepted Answer
Pro
So, you know, I have updated both EasyProfile and JCHOptimize to the latest release versions, but still the JavaScript error remains after your testing and changes. Your changes need to be reversed or explained so I can reverse them.
  1. more than a month ago
  2. Bug Report
  3. # 13
kennethefford Accepted Answer
Pro
Disabling SocialConnect again got rid of the error. The error was present with or without JCHOptimize enabled.
  1. more than a month ago
  2. Bug Report
  3. # 14
admin Accepted Answer
Admin
Hi,
sorry but I really does not understand.

What did you do? Please explain, or reverse what was done!

1. Enable Social Connect Plugin ---> No errors (tried in home page and 2 others random pages)
2. Tried to enable JCH Optimize ---> No errors (tried in home page and 2 others random pages)
3. Disabled JCH Optimize to reverse to your original configuration
Nothing More

Maybe the error is not site wide. I know I first saw it on this page,

https://sim-x.net/index.php/simsearch/custom-pwc-search-subscriber

and the account I sent you has access to that page, so you can use it to login via the front end. If you do, you need to set some filters to see how I saw the issue,
Ok, now it is all clear, in this page you have 2 jQuery instances (see screenshot from source code of this page).

Bad jquery seems to be loaded from module "mod_aridatatables" without using Joomla APIs, try to check if this module have a option to disable it.
Attachments (1)
  1. more than a month ago
  2. Bug Report
  3. # 15
kennethefford Accepted Answer
Pro
Thank you very much.

I see the issue too. For now, I have disabled SocialConnect and I will get in touch with the maker of ARI DataTables.
  1. more than a month ago
  2. Bug Report
  3. # 16
kennethefford Accepted Answer
Pro
Hi again,

I am still working on this issue. your screen grab was helpful. What is this from? Is this just the sourcecode for the page. or is it from the developer console for the browser? ARIDataTables does have the ability to disable the jQuery call and use the Joomla call for loading jQuery, but there are other problems created when disabled. I just need to track down the issue more.

Thanks in advance.
  1. more than a month ago
  2. Bug Report
  3. # 17
admin Accepted Answer
Admin
Hi,
screenshot comes from source code of the page (using Safari but it is the same with all browsers).
  1. more than a month ago
  2. Bug Report
  3. # 18
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Request Support

Support is currently Offline

Support Availability

Working days: Monday to Friday. The support staff is not available on weekends; in the most of cases tickets will not be answered during that time.

Reply time: Depending on the complexity of your support issue it's usually between a few minutes and 24 hours for paid members and about one week for free members. When we expect longer delays we will notify you.

Guidelines

Before you post: read the documentation and search the forums for an answer to your question.

When you post: include Site Details if you request a support (you can use the form below the reply in Site Details tab).

Auto Solved Question: If after a week the author of the post does not reply to a request by moderator, the question will be marked as resolved.

Language: only English

Search Users

Easy ProfileĀ® is not affiliated with or endorsed by Open Source Matters or the Joomla Project. Joomla is Free Software released under the GNU/GPL License.